Activity-watch-emacs mode does not work


#1

Hello,

i installed activity-watch-mode for emacs by instruction.

M-x install-package [Ret] activity-watch [Ret]

from melpa. I activate activity-watch-mode with

M-x global-activity-watch-mode

but it does not add a new pool and no new information to my running instance.

Any ideas?
Edit 1:
the messages buffer contained the following:

Error running timer ‘activity-watch--save’: (void-function json-encode) (14 times)


#2

The emacs watcher is maintained by @pauldub, not sure how active he is on this forum but if he doesn’t answer here you can try to create an issue on GitHub.


#3

@pauldub sadly blocked everyone from creating issues.

The package is badly written in several ways.
It forgets to
(require 'json)
but uses json-encode.
A package called projectile is required to run but it is not started or checked if it runs.
It seems to require a compatibility layer called “cl.el” but it does not load it.

I had other people who are more advanced in emacs reproduce the issues.

When i get it running i post a how to and ask him to include my changes.
Until then i find it dishonest that emacs is advertised as supported when the package does not run when installing it as the readme suggests.
If somebody get’s it working please post the relevant files.


#4

Hi @awffem !

I was not aware that issues were disabled on the repository, I have now enabled them.

As far as the package quality it is at the moment a straightforward port from the wakatime package. I have done the due diligence of refactoring according to the MELPA maintainers review.

I hope you can now submit issues and pull request at your convenience :slight_smile:


#5

@pauldub I will contact you on GitHub then. Thank you for responding.
I created 4 issues all come with a temporary work around or fixes.
I hope that you get activity-watch-mode to a point where you can install it on a vanilla emacs instance with out encountering any errors.


#6

Thank you! I will look into the issues shortly (probably this week).