Can anyone give me a hand with aw-watcher-input? (It might be an easy fix, I'm a noob)

Hi guys,

Not sure if aw forum is the best place to get an answer for this, but I would really appreciate if anyone could give me a hand.

I’m running a laptop with Arcolinux (based on Archlinux). I have my activity watcher running but I’m unable to run aw-watcher-input.

This is what I did so far:

When I type aw-watcher-input in the terminal, this is what I get:

“bash: aw-watcher-input: command not found”

I tried going to ~/aw-watcher-input/src/aw_watcher_input/ and typing “python”
this is what I got:

Traceback (most recent call last):
File “/home/victor/aw-watcher-input/src/aw_watcher_input/”, line 7, in
import aw_client
ModuleNotFoundError: No module named ‘aw_client’

How can I get this to run?

poetry install does not install the package system-wide, but only inside a virtual environment.
I have not tried this, but I assume what you need to do is to run “poetry run ./src/aw_watcher_input/” from your “~/aw-watcher-input” folder.

The reason why it’s not a good idea to not install python packages globaly and use a virtual environment like poetry instead is to avoid conflicts of package versions. So while it’s probably possible to install aw-watcher-input without poetry with something like “pip install .” it’s not recommended because some dependencies will conflict with those installed by your linux distrobution.
I use arch too btw.