Disable or prolong afk-watcher

Hi , First of all i would like to thank the developers for their awesome work.

i had this problem where i was watching youtube or any other movie and the watcher thought i was afk and didn’t count my time , i know its common and i personally think the best solution to it is the manual tracking like suggested by kerv

but for a temporary solution i tried the following with no luck :
1- disable the afk watcher , well that works but the activity tab doesn’t count anything now , only the timeline and it’s not very effective to use.

2- change the configuration of the afk time to be like after 21 min which is the average time that i wouldn’t touch the keyboard or mouse in but i couldn’t do this at all as the installing from source in windows is not done yet even if change the configuration file i can’t build it

is there is any solution for us ?
and thanks in advance :slight_smile:

There is no need to build from source for this, the config file is always available. You can find it here

C:\Users\username\AppData\Local\activitywatch\activitywatch\aw-watcher-afk\aw-watcher-afk.ini

Don’t forget to replace “username” with your username!

The setting to change is “timeout” which by default is 180s, you can change this to 6000 for it to be 100 minutes for example. Then you just need to restart aw-watcher-afk and it should work.

1 Like