Issues with Firefox, i3wm and aw-qt

I’ll try to be brief! Love the project. Having some issues…

  1. Installed from Arch package, starts and runs, but only logged first few hours of my use
  2. Firefox extension connects, logs info in Timeline, but shows nothing on Activity page from FF
  3. Firefox watcher gives unassigned device ID on Raw Data page
  4. Tried manually killing aw-qt process with top, restarting FF, but now aw-qt doesn’t even start, but the server does when I run aw-qt

Perhaps I’m not exiting aw-qt gracefully enough. I just kill the process, or ctrl+c. But maybe there’s something else going on? What am I missing?

Attaching a screenshot montage as I’m only allowed one file attached apparently as a noob here.

Ah I may have instantly solved part of it.

I ran aw-qt -i to get it in interactive mode. Couldn't connect to display "localhost:0". I did export DISPLAY=':0' and now aw-qt ran.

I’m still getting Firefox special device error, but it’s at least logging normal activity again.

Presumably, if the FF logger is working, then I just need to tie it to the correct hostname/device ID somehow to feed the data over.

Anyone got a method for that? Do I need to go find the config files for it maybe?

No docs with it that I could see, that explained anything like that at least.