Issues with nested Categories

I have raised a github issue before that I found the categorisation quite unintuitive, expecting nested categories to be a subset of the category above it, not the ‘deepest’ pattern that matches.

I have tried to use it in the intened way, but I believe I have found a bug or limitation, which I will attempt to explain.

I have configured Visual Studio to use the Window Title format:
“(Project Name)\(File Name).(Ext) [(debugging)] - Microsoft Visual Studio”

I have a parent category with this regex to catch everything for this project:
“MyProject\\.* - Microsoft Visual Studio”

Then nested below that, I try to identify tasks I was working on, using common keywords in a regex pattern like so:

However using the escaped backslash caused the pattern match to fail, and I found that when I had 3 of this sort of pattern with different keywords in each, only the first would match, but changing the order by removing and re-adding it would show that the pattern was valid and matching events for all 3 sub-categories, just not at the same time.

What I expected to see were all 3 categories listed with a total time slightly less than the parent, which tells me how much is uncategorised.

Please let me know if I am still using it wrong, or if I should raise this as an issue on GitHub.


EDIT: Removed bug solved by

Hm, that sounds strange.

I assume that you are using the latest version 0.10?
Backslashes were incorrectly escaped in 0.9

Yes, I am using the latest version. I escaped them as I have shown in my first post, which I believe is the correct way.

The commit @johan-bjareholt linked was unrelated to the specific issue you’re having, but the bug was fixed in and will be in the next release.

1 Like