New install Win10 aw-server stops unexpected on launch. Will not restart

Hey there, just installed and no matter what the server won’t start. Tried running as admin and didn’t make a difference. Logs are below for the main qt log. Checked logs for the other cores and they basically just say “not connected to server”. Also tried manually running the aw-server.exe in local\programs\activitywatch\aw-server didn’t seem to do anything. Not sure if maybe my install is somehow messed up or if I have something conflicting.

Main qt log:

2023-01-05 11:46:30 [INFO ]: Started aw-qt...  (aw_qt.main:53)
2023-01-05 11:46:30 [WARNING]: Found matching file but was not executable: C:\Users\jallw\AppData\Local\Programs\ActivityWatch\aw-qt.desktop  (aw_qt.manager:64)
2023-01-05 11:46:30 [WARNING]: Found matching file but was not executable: C:\Users\jallw\AppData\Local\Programs\ActivityWatch\aw-server-rust\aw-server.service  (aw_qt.manager:64)
2023-01-05 11:46:30 [INFO ]: Found 4 bundled modules  (aw_qt.manager:85)
2023-01-05 11:46:30 [INFO ]: Found 0 system modules  (aw_qt.manager:119)
2023-01-05 11:46:30 [INFO ]: Starting module aw-server  (aw_qt.manager:148)
2023-01-05 11:46:30 [INFO ]: Starting module aw-watcher-window  (aw_qt.manager:148)
2023-01-05 11:46:30 [INFO ]: Starting module aw-watcher-afk  (aw_qt.manager:148)
2023-01-05 11:46:30 [INFO ]: Creating trayicon...  (aw_qt.trayicon:206)
2023-01-05 11:46:30 [INFO ]: Initialized aw-qt and trayicon successfully  (aw_qt.trayicon:262)
2023-01-05 11:46:32 [WARNING]: Tried to stop module aw-server, but it wasn't running  (aw_qt.manager:185)
2023-01-05 11:46:38 [INFO ]: Starting module aw-server  (aw_qt.manager:148)

aw-server log:

2023-01-05 11:34:42 [INFO ]: Using storage method: peewee  (aw_server.main:33)
2023-01-05 11:34:42 [INFO ]: Starting up...  (aw_server.main:41)
2023-01-05 11:34:42 [INFO ]: Using database file: C:\Users\jallw\AppData\Local\activitywatch\activitywatch\aw-server\peewee-sqlite.v2.db  (aw_datastore.storages.peewee:126)