Port forward :5600 not working

Hi!
I would like to access activitywach dashboard from another computer within my local network. After configuring portforwarding on my rooter it is still not possible to access the dashboard running on localhost:5600.

It is also possible to run another server on this port at the same time without getting an error that the port is already in use. By the way, I can access my other server from outside.

I am not a network engineer, but does dashboard run on a “real” server? If so, do you have any suggestions on how I can reach my goal?

Thank you!

Be very careful when exposing ports. If you only want to be able to access aw on your local network you SHOULD NOT do any port forwarding on your router, that will expose your data to THE WHOLE INTERNET!

The two things you need to do to be able to access it on ONLY the local network is the following:

  1. verify that your firewall (if you have one) on the computer with ActivityWatch either has the port 5600 open or disable it completely.
  2. Change the binding IP address of aw-server to listen to connections coming from outside the local computer. This is done by changing the aw-server.ini files “ip” field from “127.0.0.1” to “0.0.0.0”. Where this config file is located depends on your operating system and is documented in the ActivityWatch documentation.

After that the only thing you need to do is to replace “localhost” with the local IP address of your computer, for example “192.168.0.8:5600”. This is because “localhost” means “this computer” and in your case you want to access ActivityWatch on another computer. If your OS and router supports it it might also be possible to access it with just the hostname of your computer, such as “freds-pc:5600”.

This way works both if you have it on a “real” server or just a normal computer.

1 Like

Hi

I already made all the settings you mention, but the host is still not responding even though the firewall is disabled.

image

I am using version v0.11.0

I hope you can support me and excuse my bad writing since I used the google translator. Greetings from Mexico

@Test_Test You probably just need to set cors_origins to http://192.168.2.87:5600, but note that what you’re trying to do is unsafe, see: https://docs.activitywatch.net/en/latest/remote-server.html

I’d like to do the same, access my dashboard from another computer on the same network. I changed the aw-server.toml to server = "0.0.0.0" and cors_origins = "http://192.168.1.5:5600" (192.168.1.5 being the IP of the workstation I have activitywatch on). I opened TCP port 5600 on incoming and outgoing. I can’t even connect to http://192.168.1.5:5600 on the workstation itself, only http://localhost:5600 or http://127.0.0.1:5600 work.