Win10 Build Failing On Call to node ./build.js (?)

I’m trying to build from source on Win10. When I run “make build”, it goes through a lot of steps successfully, but eventually gets to the error shown in this screenshot:

As best I can interpret the error messages, I conclude that the script is attempting to call the command

C:\_\_\activitywatch\aw-server\aw-webui\node_modules\deasync

Examining the folder “C:__\activitywatch\aw-server\aw-webui” , I see that a sub-folder “node_modules” does not even exist. The sub-folders I do have there are .github, src, static, and test. Which seems to correspond correctly with what is in the repo.

I have checked other forum questions and found several related to Win10 build, but none of their answers helped me.

I do not see how to attach a file here, but will be happy to post the full build log if that would be helpful. For now, pasting the last 60 or so lines below.

Grateful for any suggestions in how to proceed with troubleshooting!

3776 timing build:link:node_modules/webpack Completed in 455ms
3777 timing build:link:node_modules/@vue/cli-plugin-unit-jest/node_modules/jest-runtime Completed in 454ms
3778 timing build:link:node_modules/@vue/cli-plugin-unit-jest/node_modules/import-local Completed in 454ms
3779 timing build:link:node_modules/jest-environment-jsdom/node_modules/escodegen Completed in 453ms
3780 timing build:link:node_modules/node-notifier/node_modules/which Completed in 452ms
3781 timing build:link:node_modules/node-notifier/node_modules/uuid Completed in 452ms
3782 timing build:link:node_modules/webpack-dev-server Completed in 455ms
3783 timing build:link:node_modules/ts-jest/node_modules/mkdirp Completed in 452ms
3784 timing build:link:node_modules/vue-cli-plugin-webpack-bundle-analyzer/node_modules/acorn Completed in 452ms
3785 timing build:link:node_modules/@vue/component-compiler-utils/node_modules/prettier Completed in 455ms
3786 timing build:link:node_modules/recast/node_modules/esprima Completed in 453ms
3787 timing build:link Completed in 463ms
3788 info run [email protected] install node_modules/bufferutil node-gyp-build
3789 info run [email protected] install node_modules/deasync node ./build.js
3790 info run [email protected] install node_modules/utf-8-validate node-gyp-build
3791 info run [email protected] install node_modules/yorkie node bin/install.js
3792 info run [email protected] install { code: 0, signal: null }
3793 timing build:run:install:node_modules/bufferutil Completed in 366ms
3794 info run [email protected] install { code: 0, signal: null }
3795 timing build:run:install:node_modules/utf-8-validate Completed in 380ms
3796 info run [email protected] install { code: 0, signal: null }
3797 timing build:run:install:node_modules/yorkie Completed in 536ms
3798 info run [email protected] install { code: 1, signal: null }
3799 timing reify:rollback:createSparse Completed in 9302ms
3800 timing reify:rollback:retireShallow Completed in 0ms
3801 timing command:ci Completed in 93833ms
3802 verbose stack Error: command failed
3802 verbose stack at ChildProcess. (C:\Program Files (x86)\nodejs\node_modules\npm\[email protected]\promise-spawn\index.js:64:27)
3802 verbose stack at ChildProcess.emit (node:events:390:28)
3802 verbose stack at maybeClose (node:internal/child_process:1062:16)
3802 verbose stack at Process.ChildProcess._handle.onexit (node:internal/child_process:301:5)
3803 verbose pkgid [email protected]
3804 verbose cwd c:__\activitywatch\aw-server\aw-webui
3805 verbose Windows_NT 10.0.19041
3806 verbose argv “C:\Program Files (x86)\nodejs\node.exe” “C:\Program Files (x86)\nodejs\node_modules\npm\bin\npm-cli.js” “ci”
3807 verbose node v17.2.0
3808 verbose npm v8.1.4
3809 error code 1
3810 error path c:__\activitywatch\aw-server\aw-webui\node_modules\deasync
3811 error command failed
3812 error command C:\WINDOWS\system32\cmd.exe /d /s /c node ./build.js
3813 error gyp info it worked if it ends with ok
3813 error gyp info using [email protected]
3813 error gyp info using [email protected] | win32 | x64
3813 error gyp info find Python using Python version 3.9.9 found at “C:\Users\robertm\AppData\Local\Microsoft\WindowsApps\PythonSoftwareFoundation.Python.3.9_qbz5n2kfra8p0\python.exe”
3813 error gyp http GET https://nodejs.org/download/release/v17.2.0/node-v17.2.0-headers.tar.gz
3813 error gyp http 200 https://nodejs.org/download/release/v17.2.0/node-v17.2.0-headers.tar.gz
3813 error gyp WARN install got an error, rolling back install
3813 error gyp ERR! configure error
3813 error gyp ERR! stack TypeError: tar.extract is not a function
3813 error gyp ERR! stack at go (C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\install.js:164:15)
3813 error gyp ERR! stack at processTicksAndRejections (node:internal/process/task_queues:96:5)
3813 error gyp ERR! stack at async install (C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\lib\install.js:62:18)
3813 error gyp ERR! System Windows_NT 10.0.19041
3813 error gyp ERR! command “C:\Program Files (x86)\nodejs\node.exe” “C:\Program Files (x86)\nodejs\node_modules\npm\node_modules\node-gyp\bin\node-gyp.js” “rebuild”
3813 error gyp ERR! cwd c:__\activitywatch\aw-server\aw-webui\node_modules\deasync
3813 error gyp ERR! node -v v17.2.0
3813 error gyp ERR! node-gyp -v v8.4.0
3813 error gyp ERR! not ok
3813 error Build failed
3814 verbose exit 1

Never seen this before, but this seems to be the important line.

Maybe see if you have something weird with the way you installed node/npm? https://github.com/nodejs/node-gyp/issues/1871