There's no data when I'm watching a video on youtube

I watched a 25 minute videos on youtube and it only shows 1 minute. It seems like it only tracks when there is a user input, is there any way to disable this or a workaround when watching videos?

The state of this is discussed in the following thread.

same here. I’m studied all the morning (in streaming) … and it registered nothing… I didn’t write with keyboard or use the mouse because I’m writing on paper … on my physical notes. I suggest to modify the Afk watcher.

Hello ! similar issue here : 3 hours meeting on Microsoft Teams, and nothing recorded. Despite I actively used my mouse during 1/3 of the meeting.

If you used your mouse that’s a different issue, that should work fine.

Was there literally nothing recorded or just less than you’d expect?

Hello Johan, here some more detailed infos about the issue :slight_smile:
in the time line, I get a recording for my TEAMS video call, trough the AW-Watcher-Window. The name of the entry in the timeline is “Teams.exe”

The real duration of the meeting is about 1,5 hours. But in the summary of time of use, the Microsoft Team video-call app is only displayed for 10 minutes.

Does the 10 minutes corresponds to the times where I was actually using the mouse during the meeting ?

Any idea how to handle it ?

PS : I have read something about placing an analog Watch below the Optical mouse in order to have the mouse movement recorderer … Haha :smile:

Aha, then it works as expected. You are considered active if you are either using your mouse or keyboard so that’s what those 10 minutes should refer to.

We will hopefully add an option in the future to consider time not-afk even if there is no mouse or keyboard activity.

I changed my AFK timer to 60 minutes, 30s polls and I’m having a lot of success with that. I might propose changes to the docs.acitivitywatch.net but I don’t want to suggest something that will need to be removed in a couple months. I’m too new to programming to be helpful with the code part, but I can help with documentation.

Before I was getting durations of 0-5 seconds, now I’m getting times that are much closer to my actual usage (a 7 min youtube video = 7 minute duration in the log).

I also changed my computer settings to go to sleep after 1 minute of inactivity and between that and the poll time change I’m getting good results.

1 Like

I changed my AFK timer to 60 minutes, 30s polls and I’m having a lot of success with that. I might propose changes to the docs.acitivitywatch.net but I don’t want to suggest something that will need to be removed in a couple months. I’m too new to programming to be helpful with the code part, but I can help with documentation.

I’m having a similar problem and think that your solution would work nicely. Could you share how you changed the AFK timer?

The instructions are in the docs. net area, they go like this:
Go to this folder:
~/Library/Application Support/activitywatch/

Open the afk folder, open the .ini config file

Change the timer, save, quit activity watch and relaunch or reboot

1 Like

Sorry but I’ve never heard of that directory. I’m using windows 10 and the closest thing I could find that matches your description is the aw program files folder. But there are no ‘.ini’ or ‘config’ files under that path. Also, the docs. net site currently can’t be reached due to “not able to find IP address”, for whatever reason, so I can’t seem to be able to read it at the time being. Could you please provide instructions on how to find the said config file?

I’m on a mac so I can’t help w/ windows. Try this:
https://docs.activitywatch.net/en/latest/directories.html#config-directory

The config file should be somewhere in the afk folder. I only have one config file in the afk file.

Also remember to change your screen saver time because that will serve as your afk timer if you set the actual afk watcher to be 60 minutes. My screen saver is set to 1 min.

1 Like

Found it! Thanks a ton!

Edit: what does ‘poll time’ mean? should I change this to 1h too?

Ya no problem. If you have a 10 minute timeout and a 1 second poll, then at 10:01 the poll will notice that you are over your timeout. If your poll is 60 seconds instead, then at 10:01 the poll will not notice you are over time, not until it polls again in 59 seconds (eg. at 11minutes). So poll is the precision of your timeout period, and functions like the actual countdown timer you’d expect to be working somewhere. At least that’s my interpretation of it. I don’t think you need to change the poll time, I just am not too interested in precise timeout.

1 Like

If that’s the case, maybe I’ll increase it a bit if I’m having battery issues. : )

I have been having great results since I changed the AFK timeout. Thanks for the support!

While the workaround of editing the timeout for the AFK watcher kinda works, it has some significant downsides since it affects how the data is logged, instead of merely how it’s aggregated and presented. It’ll likely make ActivityWatch vastly overestimate the time you spend on your computer, assuming you often take breaks shorter than an hour.

In the Activity view of the web UI we run a transform we call a “flood” after we retrieve the events we need from buckets. This effectively removes small gaps (<5s) where there is no event by “flooding” the empty time interval with one of the surrounding events.

In the case of the AFK watcher, this flooding approach could be used with a higher gap limit to effectively emulate setting the aw-watcher-afk timeout higher, without having to reduce the “AFK sensitivity/timeout” of the watcher itself (keeping the resolution of the AFK data intact).

I’m looking into making this a option in the web UI, following the “Filter AFK” and “audible-as-active” options that will be shipped in v0.11